• June 8, 2015 at 12:27 pm

    Please use this thread to ask any support or help related questions.

  • June 8, 2015 at 12:34 pm

    For some reason the Garage no longer remembers my log in. Have to log in every time I visit. Only have the problem on this site.

    Make sure your browser is set to accept cookies from garage.roushperformance.com

    http://windows.microsoft.com/en-us/windows-vista/block-or-allow-cookies

    https://support.google.com/accounts/answer/61416?hl=en

    https://support.mozilla.org/en-US/kb/enable-and-disable-cookies-website-preferences

    I can lot out and back in on all other sites and it will remember my log in. Just not on this site. Will not remember on Firefox or IE. Just started for some reason. I have gone through the Firefox options with a fine tooth comb. Nothing makes a difference on my end.

  • June 23, 2015 at 8:34 am

    When I went into the RRC site a few minuets ago the red notification box was on an said I had 3 new replies and 132 friendship requests so when I logged in the red box went away and there is nothing on my profile page for requests or notifications ????

  • June 23, 2015 at 9:07 am

    Well this time when I went out and back in the Red Notification Box was on again and it now says
    You have 3 notifications
    You have 7 pending friendship requests
    You have 132 new messages
    You have 44 new replies
    So when I hit my log in info the notification red box goes away and there is nothing on or in my page to find anything so what the crap is happening ?

  • June 23, 2015 at 9:26 am

    Well this time when I went out and back in the Red Notification Box was on again and it now says
    You have 3 notifications
    You have 7 pending friendship requests
    You have 132 new messages
    You have 44 new replies
    So when I hit my log in info the notification red box goes away and there is nothing on or in my page to find anything so what the crap is happening ?

    At this time you need to click on the notification box to make them go away. You can also view all of your notifications by going into your profile. This is definitely on our list of upcoming changes.

    That’s a lot of private messages, let me know if any of them look like spam.

    **edit**

    Just noticed your previous post, If you’re getting notifications about messages that don’t exist that’s an issue for sure. can you post a screen shot of what you see? (make sure there isn’t any private information in the cap)

    • This reply was modified 1 year, 7 months ago by Profile photo of Thad@ROUSH Thad@ROUSH.
  • June 23, 2015 at 9:49 am

    Just saw the same notification. I’m assuming this is related to the recent changes (for the issues with sessions expiring) We’ll look into this, for now it’s nothing to worry about, not a security risk, just a minor annoyance.

  • June 23, 2015 at 10:07 am

    Ok just wanted to make sure if members were trying to friend or reply to me that i was not just ignoring them i tried to get the screen shot to work but for some reason it won’t so i took a pic of it with my cell phone if you need to see it send me an e-mail and i will send it to you

  • June 23, 2015 at 10:54 am

    Ok just wanted to make sure if members were trying to friend or reply to me that i was not just ignoring them i tried to get the screen shot to work but for some reason it won’t so i took a pic of it with my cell phone if you need to see it send me an e-mail and i will send it to you

    No need, Seeing it for myself confirmed the issue. Also heads up, I removed your email from the previous post, wouldn’t want that to fall in the wrong hands. This forum is public now so posting personal info is risky. (RRC section is still private)

  • June 23, 2015 at 2:34 pm

    Thanks forgot about goin public on this side.

  • July 13, 2015 at 6:51 pm

    Sorry Thad, but it keeps getting worse. Have cleared cookies and cache. Still get the red box every time I visit. And now it won’t let me log out. Why don’t they just get a working message board and be done with it………..

  • October 17, 2015 at 11:09 pm

    What is the 0-60 for the 2016 Ford Mustang GT Stage 3 Roush?

  • December 22, 2015 at 8:47 am

    I am unable to view the Crew News. I get some message, “Sorry you are unable to view” or something like that.

    Also, I see the notifications on the bottom right in red when I visit the forums but nothing else will happen if I click on them.

  • December 22, 2015 at 12:05 pm

    Brian,

    Make sure you are logged in to your account and check Crew News again. As a rule of thumb, as soon as you get to the Garage site, click Home in the upper right corner. That will refresh the page, delete the red notifications, and should log you in to see the Crew News. If you still have issues, let us know!

    Stephanie

  • December 23, 2015 at 12:28 pm

    Thanks for the fast reply, but it still gives me the same response

  • December 23, 2015 at 1:22 pm

    Just shoot me an email: Stephanie.Davies@roush.com, and I’ll forward you over to our tech support to get you added to the list.

    Thanks!

    Stephanie