• August 3, 2016 at 10:30 am

    Hi Everyone, just a friendly reminder we have switched over from this current site to a new one ran by Member Planet which allows us to offer more to everyone, If you are not on yet, please check your email from May 10th with the instructions on how to create your profile on new site, which will allow pics of yours cars etc. Please start new discussion threads on Member Planet as we are no longer monitoring this current site. please email me directly if you have any issues. mike.rey@roush.com

  • August 16, 2016 at 9:05 pm

    I just see blank pages on MemberPlanet. I set up my profile, but there’s nothing on any of the other pages. Is something wrong?

  • August 18, 2016 at 12:37 pm

    I don’t believe there is anything there Angie, I see the same thing which is nothing. I can see events and two discussion topics Mike started with no responses. A see I think 7 photos. If there is really nothing posted since May, it’s a sad to see. Have you tried posting? I have not. I don’t have much good to say and it would probably be deleted.

    • This reply was modified 5 months, 1 week ago by Profile photo of Jay Jay.
  • August 18, 2016 at 4:37 pm

    I have tried posting. When finished and hit publish the topic will show up, but the body and all of the text of the topic that I typed is gone…no where to be seen. I’ve even tried to post in the Suggestions area and it does nothing. I hard to suggest fixes when the suggestion area won’t take your suggestions.

    I’ve tried and tried to post stuff ever since it came out in May….but still nothing.

  • August 19, 2016 at 2:59 pm

    Thanks Jay and Dave! I thought it was just me. I don’t know how we’re supposed to use something that clearly doesn’t work. I even asked on the Facebook page but no one responded.

  • August 23, 2016 at 4:54 pm

    Hi Angie, what pages are you referring to exactly?

  • August 25, 2016 at 8:31 am

    Hi Angie, what pages are you referring to exactly?

    Mike it is every page. it appears we all have the same issue that I complained to you by email a few weeks ago that still has yet to be resolved, we get to Memberplanet and log in, it takes me to the Roush page, where we see the inbox and for example I see a post “is anyone on here” click on that I see no posts. Under discussions we see your two posts “Member planet is launched” and “suggestion board”, no responses and when you try to respond it just goes into hyperspace never showing up. You all should really test your websites/pages well before telling people to go there and start using it.

  • August 25, 2016 at 10:56 pm

    Mike it’s exactly what Jay says. I can’t attach a picture here but I did attach a screen shot on my Facebook post on 8/16.

    On the Discussions Page it says No Discussions to Display. I click New Topic, type an entry, click publish, and the main Discussion Page still says No Discussions to Display. I just entered one!!

  • August 26, 2016 at 9:02 am

    Mike…when we try to post to anything, our posts don’t appear…only the topic that we typed in appears. It doesn’t matter if it’s in Discussions or the Inbox. The posts that we type disappear and we can only see the 2 posts that you posted. I tried to leave a reply to you in the Suggestions thread, but everything I typed just disappeared when I hit Publish….no topic, no body of text…nothing. I tried posting a photo, but got nothing and eventually was taken to an Error page.

    In regard to the email that I sent to you about these issues and you said you’d forwarded my email address to MemberPlanet and you were sure they would get back to me to try to resolve the issues….we’ll I’ve never heard from them and it’s been over 2 weeks now. I don’t think they are going to contact me at all.

    I don’t believe the site is working for anyone, or I’d have seen at least one other post from someone other than you or the RRC by now.

  • August 29, 2016 at 8:35 pm

    I sent an email with Dave’s last post to Mike and Greg Bielstein at Memberplanet, received the following today from Greg. I’m not so sure this is the issue though??

    All posts must be approved by admins before being visible to all members. I’ve reached out to Mike and will plan to connect with him tomorrow on this.

  • August 30, 2016 at 12:25 pm

    Hmmmmmmmm….interesting! If true, I suppose it’s “safety” issue on not letting unwanted posts to be shown. On the other hand, I’m sure Mike doesn’t have the time to babysit the forum and approve posts to go through and be posted…it could be days before a post gets seen, when the subject of the post might be time sensitive.

    I sent another email to Mike, detailing what I can and can’t do on the site…for him to forward to Memberplanet for resolution. Hopefully, something will get resolved in the not to distant future.

  • August 30, 2016 at 12:41 pm

    Dave, all posts on member planet should now be visable and active. Literally just went through a process with Greg!

  • August 30, 2016 at 12:41 pm

    All posts have now been approved and made public to post on! :)

  • August 30, 2016 at 9:50 pm

    I just replied to a couple post’s successfully, my months of complaining and recent emails finally paid off…

    and Mike, YOU’RE WELCOME!

  • August 31, 2016 at 8:46 am

    Nice to see it finally working like it is supposed to work.

    Now, maybe some folks will begin to use it on a regular basis.

    Mike, I’d recommend posting on the RRC Facebook page that the issues with the new website have been mostly resolved and that it is open for business. Otherwise, I doubt you’ll get much usage there. I know of a lot of folks who tried it and when it didn’t work, just said screw it and never went back. Might be good to let them know that if should work for everyone now.